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Release Notes for Modo 11.2v2
Release Date

19 December 2017

System Requirements

Officially Supported Operating Systems
• MacOS 10.10.x, 10.11.x, and 10.12.x (64-bit only)
•Windows 7,Windows 8, andWindows 10 (64-bit only)
• Linux 64-bit operating system (CentOS/RHEL 7+)

Minimum Hardware Requirements
• Intel processor(s), Core i3 or higher
• 1 GB available hard disk space (for Modo installation).
• 6 GB available hard disk space (for full content).
• At least 4 GB RAM
• Display with 1920 x 1080 pixel resolution
• Internet connection for product activation and online videos access
• The Advanced viewport mode requires an NVIDIA or AMD graphics card with at least 1 GB of graphics
memory and drivers that support OpenGL 3.2 or higher.

Recommended System Requirements

NOTE: This information is our best recommendation for the average user. Requirements vary by
usage, and individual usersmay have different requirements from those listed here.

• 2.5+ GHz quad-core processor
• 250+ GB disk space available for caching and temporary files, SSD is preferable
• 16GB RAMwith additional virtual memory*
• Display with 1920 x 1080 pixel resolution
• An NVIDIA or AMD graphics card with the latest drivers
• 2+ GB of graphicsmemory
• OpenGL 4.4 or higher support

*The use of virtual memory improves stability and helps prevent data loss on large projects.
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TestedWorkstation Hardware

The configurations listed below are those that Foundry have tested with Modo. Due to the constantly changing
nature and wide variety of computer hardware available in themarket, Foundry is unable to officially certify
hardware. The list below can be used as a recommendation and does not guarantee that it meets your particular
needs.

Please download and install the latest graphics driver from the NVIDIA or AMD websites. Make sure that you
are using 8.982.8.1 drivers or higher for AMD cards.

If you encounter any issues, please visit the Support Portal at https://support.foundry.com.

Tested Workstation Hardware

Apple • MacBook Pro 2017
• MacBook Pro (Mid 2015)
• MacBook Pro 2014
• MacPro (Late 2013)
• MacBook Pro10, 1
• MacPro4, 1
• MacPro5, 1
• iMac13, 2

Dell • Dell T1700
• Dell T3610
• Dell T3620
• Dell T5810
• Dell T7610
• Dell T7910
• Dell Precision 3520
• Dell Precision Rack 7910
• Dell Precision 5510
• Dell Precision 5520
• Dell Precision 7710
• Dell Precision 7720
• Dell M2800
• Dell M6800
• Dell XPS 15 9560

HP • HP Z800
• HP Z640

| TestedWorkstation Hardware
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Tested Workstation Hardware

• HP Z620
• HP Z600
• HP Z440

Tested GPU Hardware

AMD Prosumer Graphics Cards • Radeon™ HD 1900 XT
• Radeon™ HD 2400 XT
• Radeon™ HD 2600 Pro
• Radeon™ HD 3870

AMD Enterprise Graphics Cards • FirePro™ D700
• FirePro™W4170
• FirePro™W5000
• FirePro™W8000
• FirePro™W2100
• FirePro™W5100
• FirePro™W4100
• FirePro™W7100
• FirePro™W8100
• FirePro™W9100
• Radeon Pro 560
• Radeon ProWX7100
• Radeon ProWX5100
• Radeon ProWX4100
• Radeon R9M370X

NVIDIA Prosumer Graphics Cards • Geforce GT 750M
• Geforce GTX 680
• Geforce GTX Titan
• Geforce GT 650M
• Geforce GTX 1080 Ti
• Geforce GTX 1080

NVIDIA Enterprise Graphics Cards • Quadro® K6000
• Quadro® K5200
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Tested GPU Hardware

• Quadro® K5000
• Quadro® K4200
• Quadro® K4000
• Quadro® K2200
• Quadro® K2000
• Quadro® K1200
• Quadro® K600
• Quadro® K620
• Quadro®M5000
• Quadro®M4000
• Quadro® P4000
• Quadro®M620

NVIDIA Quadro Graphics Cards: • P400
• P600
• P1000
• P4000
• P5000

New Features

There are no new features in this release.

Bug Fixes

• BUG ID 53867 - Licensing: LaunchingModo after downloading the installer from our website occasionally
causedModo to crash.

• BUG ID 55702 - UI: Saving an empty custom layout causedModo to crash.
• BUG ID 56433 - Preset Browser: Cloud-based assets could not be downloaded.
• BUG ID 57003 - Procedural: The Booleanmesh operation applied an inverse scale to the item beingmodified.
• BUG ID 57011 - Windows only: Using the Bridge tool on two polygons created fromBezier Curves caused
Modo to crash.

• BUG ID 57014 - UV: Using the Spit and Sew tool in Sew mode sometimes causedModo to crash.
• BUG ID 57015 - Model: Dragging the Bevel Edge tool to the left in the 3D Viewport causedMitering.
• BUG ID 57027 - GL: Incorrect culling of items occurred, which resulted in selecting hidden itemswhen another
layout was initialized.

• BUG ID 57137 - Model: The Polygon Bridge tool left points with no polygons behind.

| TestedWorkstation Hardware
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• BUG ID 57138 - Model: Using the Loop Slice tool on a polyline causedModo to crash.
• BUG ID 57147 - UV: Enabling the UV Coverage option in the Preferences and then addingmultiple meshes
without UV maps sometimes causedModo to crash.

• BUG ID 57149 - Model: Snapping activation using the keyboard shortcut caused unexpected behavior.

Known Issues and Workarounds Specific to Modo 11.2

This section covers known issues and givesworkarounds for them, where appropriate.

Advanced Viewport
• BUG ID 56706 - Unity and Unrealmaterials are not displayed correctly when first loaded.

As a workaround: Enable and then disable the visibility of the Shader Tree textures.
• BUG ID 55594 - Wireframe ismissing from orthographic views.

As a workaround: Change Line Antialiasing from Full to either Off or System.
• BUG ID 50810 - Anisotropic texture filtering is lower quality than in the Default viewport.
• BUG ID 46995 - Ambient Occlusion display in the Advanced viewport is affected by selected itemwireframes.

You can disable Show Selection in the Visibility options or disable wireframe drawing on the activemesh
layers.

Animation
• BUG ID 53661 - Selecting actions does not always select the correct one. This is caused by copying actions.

As a workaround, manually edit the tags on the broken actions by selecting them in theGroups tab, then save
and reload the scene.

Assemblies
• BUG ID 36452 - Assemblies exported from the Item List context menu result in poor visual layout of nodes on
import.

As a workaround, you can save assemblies from the Schematic viewport.

Baking
• BUG ID 50671 - Baking displacement maps can cause UV seams to be visible, and the baked displacement
map to show quilting effects and other render artifacts.

• BUG ID 49437 - The Bake Channel Swizzling option can’t bake to texture alpha.

| Advanced Viewport
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Color Management
• BUG ID 49244 - (Windows only): With Perform Color Correction on, setting a default scene to a scene with a
mesh that has a position channel crashesModo at launch.

As a workaround, use System > Reset Preferences to reset to defaults or move/remove the default scene.

Default Viewport
• RGBA textures only draw correctly in the Advanced viewport. In the Default viewport, any unsupported
texture effect on an imagemap is drawn as diffuse color when the layer is selected in the Shader Tree.

Deformers
• BUG ID 56726 - Deformed Instances that are off-screen are incorrectly drawn at the origin.
• BUG ID 55470 - Freezing amesh with normalized deformers and aMeshOp causedModo to crash.

File and Image I/O
• BUG ID 56862 - Modo for SolidWorks Kit: Modo crasheswhen importing the same SolidWorks file twice in
oneModo session. This bug only affects import using the kit, not direct imports (File > Import).

As a workaround: Before importing a SolidWorks file for the second time, exit and restart Modo.
• BUG ID 55439 - Alembic imported convex polygonswith at least two close to co-linear edgesmay not draw
correctly in GL (appearing asmissing triangles).

As a workaround: Import using the new Alembic Streaming options. Set the Polymesh streaming options to
Alembic Streaming Meshes (polys only, force all). Alternatively, select the basematerial in the Shader
Tree and enable Surface Normal > Double-sided, then change the Smoothing angle to 180.

• BUG ID 50198 - Alembic scenes don't export some surface items, including staticmeshes and procedural
shatter items.

• BUG ID 49728 - Exporting selected layers (from the Item List context menu) to .fbx doesn't export instances,
unless the original mesh is also exported.

To resolve this, set the .fbx preference to Export Selection and use Export As….
• BUG ID 47036 - Color management in .svg images is not currently supported. This is a side-effect of a bug fix
where the largest allowable image size (64k x 64k) was always used when color correction was enabled.

• BUG ID 46962 - Rendering .svg images used as stencil maps for displacement or for layer masking can be
very slow.

Fur
• BUG ID 35731 - Fur length textures can’t be edited with the Stretch tool.

| Color Management
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Use different fur length drivers, such as hair guides or vector vertexmaps.

General
• BUG ID 49514 - MacOS X only: Runningmodo_cl before running the UI Modo application breaks code
signing.

As a workaround, start the UI version of Modo once, before runningmodo_cl on any systemwhere you later
intend to use the UI version.

GL
• BUG ID 55816 - Wireframes are washed out on transparent surfaces in the Advanced viewport.

As a workaround, avoid transparencywhenmodeling or doing work where wireframes are needed.
Alternatively, use the Default viewport.

• BUG ID 55746 - Moving themouse over a procedural mesh, when Animation > Enable Deformers is off, may
causeModo to crash.

• BUG ID 55594 - Wireframe overlay ismissing in orthographic views if Line Antialiasing is set to Full in the
Advanced viewport.

As a workaround, use the Line Antialiasing > System or Off option instead.
• BUG ID 55500 - Setting the Advanced viewport Effects > Material option to Basic displaysUnrealmaterials
aswhite.

As a workaround, use Simplemode.
• BUG ID 55145 - Default viewport lights are not casting shadows in the Advanced Viewport.
• BUG ID 54456 - GL count is incorrect in certain circumstances, including whenmeshes are displayed in
wireframemode or when displaying replicas.

•Windows only: Using Raptr can causeGL driver crashes inModo.

Input Devices
• BUG ID 51741 - MacOS X only: Modo sometimes becomes unresponsive when using the combination of a
click-drag in a tree view (for example, when toggling the visibility of two successive items in the Shader Tree),
followed immediately by a two-finger scroll gesture on some devices, including laptop trackpads and theMagic
Mouse.

As a workaround, change to a 3-buttonmouse (recommended to fully access all of Modo's features).
• BUG ID 35856 - Linux only: Plugging in aWacom tablet while Modo is running can cause undesired
movement. This cannot be fixed, due to a limitation of the hardware driver.

To avoid this, plug in the tablet before application startup or restart.

| General
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Item List
• BUG ID 53209 - Group creation (Ctrl + G) places the new group folder at a random position in the Item List, if
the items are not selected in a top down sequence.

As a workaround, select the items being grouped from top to bottom in the Item List before grouping (Ctrl +
G).

Mesh Fusion
• BUG ID Bug 56973 - If a Trim Fusion role is assigned to an object and then it is dragged and dropped onto a
Primary, the dropmenu does not contain the Trim boolean options.

As a workaround, use either the Fusion Buttons (Tool palette - Set Mesh Role & Apply section) or PieMenu
(Apply SubtractionApply Intersection or ) when initially adding Trims to each Fusion Item (Trims can
contribute tomultiple Fusion Items). If initially applied with either of thosemethods, all subsequent Drag &
Drop optionswill be supported.

Modeling
• BUG ID Bug 55857 - Using theModel layout Toolbox Basic subtab Center Selected option on a polygon
selection, with multiple mesh layers selected, doesn’t center to the origin.

As a workaround, select only onemesh layer at a time or put all geometry in one layer.
• BUG ID 55842 - Using the Tack tool, with Align, Copy Geometry, andMake Bridge options enabledmay
causeModo to crash.

• BUG ID 32728 - Zooming out with a Space Navigator alters theWork Plane position.

Network Rendering
• BUG ID 48325 - Sceneswith image sequences rendered with Full Frames use the wrong image sequence
number on slavemachines.

As a workaround, use File > Consolidate Scene, then render the scene using a shared network folder
(Preferences option under Rendering > Network Rendering).

• BUG ID 36986 - Slaves render hiddenmeshes. Sincemesh hide state is not stored in the scene, when that
scene is transferred to the slaves, the state is lost. Themaster respects the hidden state, however.

As a workaround, if the intent is to avoid rendering, toggle the visibility for the item or render or open System >
Preferences > Rendering and disable Use Network Render Nodes.

• BUG ID 30318 - Network Rendering doesn’t support Realflow particles.
• BUG ID 25636 - Frame passes are not supported.

| Item List
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• Several Bugs - While it apparently worked inModo 902, in some cases, Network Rendering was not
implemented to support baking. Changes toModo in the 10-series apparently broke what wasworking for
some artists, so the functionality has been disabled.

As a workaround, Modo 10 implemented the ability to Network Bake using Bake Items and an external render
controller. For more information, please see the SDKWiki.

Node Shading
• BUG ID 50642 - Nodal shading does not support UDIMs.

Painting/Sculpting
• BUG ID 41682 - Textures are not always updating in Preview/Render when painting on an imagemap.

You can save and reload the image to force the update.

Particles
• BUG ID 44551 - Surface Particle Generatorsmay not update with changes to a Density Gradient Input set to
Slope.

As a workaround, choose Distance to Locator or any other setting from the Density Gradient Input
dropdown, then change it back to Slope.

• BUG ID 34925 - Re-opening scenes saved with large particle caches can cause problems.

To avoid such issues, delete the cache before closingModo, or export the particles to .csv cache files or
Realflow .bin files. You can do this by attaching one of those nodes to the Particle Simulation item in the
Schematic viewport, and clicking Cache Simulation.

Preset Browser
• BUG ID 55882 - Pinning the Viewport Textures preset browser crashesModo on restart.

As a workaround, runModo in Safe Mode and select System > Reset Preferences or manually delete the
main config file.

Presets
• BUG ID Bug 55867 - Dragging and dropping a preset material into amaterial group places the preset above
the Base Material, not in the group.

As a workaround, move the preset material group after dragging and dropping it.

| Node Shading

http://modo.sdk.thefoundry.co.uk/wiki/Network_Rendering#Networking_baking_via_render_farm_controller


10

Preview
• BUG ID 55901 - Preview is rendering imageswith the wrong color space for non EXR images.
• BUG ID 55646 - The Camera can’t be edited in Preview if any of its channels are locked.
• If a high polymesh is not visible, the Preview baking output will be incorrect.

As a workaround, reset Preview to fix the baking.

Procedurals
• BUG ID 56908 - Merge Meshes can corrupt UVs created inMesh Ops.
• BUG ID 56318 - Procedural duplication of MeshOps in a Deform folder creates errant Mesh Ops list.
• BUG ID 56317- Duplication of Procedurals does not work with the Select By Previous Operation tool.

As a workaround, manually edit the duplicate's Select By Previous OperationMeshOps.
• BUG ID 54738 - A duplication of any item that is aMergeMeshes Source (For example, aMesh Item,
Procedural Item, or Fusion Item), any duplicates (duplicate or instance) are added to theMergeMeshesOps
List as a source.

As a workaround, remove the unwanted additionalMergeMesh Sources (regardless of the type of source) in
theMesh Ops List using the X icon in that list next to eachMergeMeshes source.

• BUG ID 52149 - Curve Extrudemesh operation: The Path Segment Generator's Align to Normal option
doesn't work when using a Bezier with zero-length tangents.

As a workaround, rotate the polygons to point toward the +Z before extruding or make sure there are no zero-
length tangents.

• BUG ID 49767 - Scenes, which contain a UV constraint modifier driving texture properties, may fail to load
after saving, due to amodifier dependency loop.

• BUG ID 46512 - When rigged, Rock items and other procedurals do not display correctly in GL. This is a
limitation of the feature and will not be fixed.

You can use Preview or RayGL to visualize the variations from rigging.

Projections
• BUG ID 49473 - Projections are incorrect if the projecting camera is set to Vertical film fit mode and the width is
less than the height.

• BUG ID 43771 - Camera projections from non-render cameras show distortion in GL and baking.

To avoid this, make sure that the projection camera has a filmwidth-to-height ratio that matches themain
render camera.

| Preview
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References
• BUG ID 44492 - If a scene that already contains references is referenced, the shading of the original
referencesmay not persist.

As a workaround, limit sceneswith shading to one level of reference.
• BUG ID 41119 - Reloading a reference after replacing it with the same file can causeModo to crash.

Rendering
• BUG ID 56620 - Modo crasheswhen closing a scene containing a referenced scene after attempting to revert
a reference override.

As a workaround: First close and reopen the scene before attempting to revert the reference.
• BUG ID 56585 - The Render Current View command, with Preview running, may cause an error.

As a workaround: Pause Preview before rendering.
• BUG ID Bug 55787 - The Scratches procedural texturemay produce NaNs in the Preview viewport and
Render Display.

• BUG ID Bug 55663 - Motion Blur applied on a curve in aMeshOperation no longer works.
• BUG ID Bug 55262 - Displacement combined with normalmaps renders incorrectly.

As a workaround, enable the Displacement as Bump option in the Render Item Settings or render using
Preview.

• BUG ID 53411 - Mesh lights or any direct light too close to a surface can produce fireflies (hot pixels) in some
cases.

As a workaround, use aMaximum Radiance higher than 1W/srm2 to reduce the bias.

• BUG ID 53793 - Rendering using a Dual CPU with 72 threadswas significantly slower than expected.

As a workaround, anymachine that hasmore than 32 cores, performance will be better if you limit rendering to
half the number of cores you have.

• BUG ID 53184 - Value presets created for material Subsurface Scattering samples in Modo 10.1 or earlier
now show on the render item instead.

• BUG ID 52730 - The Vertex Illumination Bake command doesn't work as expected, when themesh has
transform channels.

As a workaround, freeze the transforms in themesh properties.
• BUG ID 52011 - Tangent Basis handlesMirror UVs incorrectly.

As a workaround, applyMikk or any other tangent space basis to themesh before baking.

Rigging
• BUG ID 55059 - Binding can’t be usedmultiple times in Setupmode.

| References
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As a workaround, exit and re-enter Setupmode.
• BUG ID 27244 - Duplicating joints in a boundmesh retains influences from the original joint chain.

Schematic
• BUG ID 55859 - Dragging and dropping a Texture Locator, Camera, or Light from the Shader Tree into
Schematic viewport doesn’t work.

As a workaround, with the item selected, click the Add Selected button in the Schematic viewport.

Scripting
• BUG ID 53458 - Right-clicking or running a script in the Script Editor can lock up input to Modo.

As a workaround, click in the top window of the Script Editor, use themainmenus, or change to another
application, then switch back toModo.

• BUG ID 55138 - Modo crasheswhen undoing a script which uses removeItems.

Sculpt
• BUG ID 55897 - Specular and shadows in the Default viewport stops showing when sculpting on a
displacement image.

As a workaround, use another viewport mode such as Advanced or Reflection, or apply aMatcap shader to the
Shader Tree.

Shader Tree
• BUG ID 37858 - In the Shader Tree, choosing a group fromAdd Layer > Image Map > (use clip browser)
fails.

To work around this issue, in the Clip Browser, choose a single image instead of the group, and then change
to the image group using the Texture Layer's Properties tab.

• BUG ID 30947 - Layer masking displacement does not work unless you drag and drop themasking layer onto
the displacement layer.

Topology
• BUG ID 55887 - In Removemode, the Topology Pen doesn’t remove edges created by the Split mode but
instead removes the underlying polygon.

Unreal and Unity Materials
• BUG ID 50701 - Unrealmaterial Ambient Occlusion does not bake correctly in Modo.

| Schematic
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• BUG ID 50700 - There is no way to visualize the Unreal SubSurface Color effect in Modo.
• BUG ID 50451 - On some graphics cards, Unitymaterial may cause flickering in the Advanced viewport when
used with bumpmaps and shadows.

UI
• BUG ID 55759 - Transforming objects can cause the Items Properties panel to flicker.
• BUG ID 55702 - MacOS X only: Saving layouts on certain multi-display configurations causedModo to crash.

As a workaround, having your primary display as the left-most, may prevent this.
• BUG ID 55571 - Resizing the dopesheet in Zen crashesModo 11.1, but not in Modo 11.0.
• BUG ID 55185 - Text in the viewport icon buttons is not visible in the Advanced viewport on someMac
OS/AMD configurations.

As a workaround: UpgradeMacOS to 10.12 or 10.13.
• BUG ID 44496 - MacOS X only: Disabling Affect System Color Dialog in Preferences > Rendering > Color
Management, and using the system color picker caused colors to darken with each use of the color picker.

This is due to anOS X issue, which requires the color profile in both themonitor settings and color picker to be
set to sRGB IEC61966-2.1.

• BUG ID 44896 - Dragging and dropping an image from disk into the Clips list doesn’t work.

If the Clips list is empty, drop the image onto the bar at the top, otherwise drop it above or below other images
in the list.

• BUG ID 43162 (Windows only) -Setting a custom text size affectsModo's text drawing.

As a workaround, go to the compatibility settings by right-clicking theModo shortcut or executable, and turn off
font-scaling for the application.

UV
• BUG ID 56967 - If UV distortion is enabled in both the UV and 3D viewport, editing themesh in the 3D view
causes the UVs to turn black.

As a workaround: Toggle the UV texture visibility or avoid enabling Show Distortion on in both views.
• BUG ID 55891 - Show UDIM does not display the UDIM number in the UV viewport.

As a workaround, enable the Auto Spans option.
• BUG ID 55582 - The Tear-off modifier keys (Shift+ Ctrl) are live in the UV Transform tool, meaning the Tear-
off state changes during the drag if the keys aren’t held down.

• BUG ID 55564 - The UV Distortion and UV Vertexmaps are no longer accessible. This is due to bugs and
crasheswith these ‘internal’ maps being visible to users. Modo 11.2 will introduce features to replace prior
uses of thesemaps.

| UI



14

Developer Notes
• BUG ID 53988 - SDK: The item.channel query didn't read evaluated strings correctly.
• BUG ID 55473 - SDK: A reference scene loaded twice did not return geometry in CLxSurfaceVisitor.Sample
().

• BUG ID 55749 - SDK: Viewing graph for a plugin's alpha channel, if no keyswere set, causedModo to crash.
• BUG ID 56467 - SDK: Reading an item graphs in a command's enable function sometimes causedModo to
crash if the scene changed.

• BUG ID 56697 - SDK: Rendercache crashedModowhen closing the scene.

| UV
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